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ObjectifsObjectifs

> Prise en main de l’environnement ANSYS Electronics Desktop (V16) – HFSS

> Création d’un projet from scratch

> Flot de modélisation et post-processing typique

> Utilisation des différentes solutions (driven modal/terminal modal) et excitations 
(wave port/lumped port)

> Calcul des paramètres S

> Calcul tensions/courants à l’aide de la calculatrice de champ

> Calcul du rayonnement en champ proche et champ lointain

> Influence du maillage
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ANSYS Electronics DesktopANSYS Electronics Desktop
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HFSS – méthode FEMHFSS – méthode FEM
> Finite Element Method : résolution numérique des équations de Maxwell à l’intérieur d’un 

volume délimité (solution space) et maillé par des tétraèdres, aboutissant au calcul des 
champs E et H dans ce volume ainsi que la matrice de param. S généralisés.

Maillage + 
fonction de base

Résolution 
système linéaire

Dépend des 
conditions aux 

limites+matériaux

Dépend des 
excitations aux ports 
et ondes incidentes
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HFSS - InterfaceHFSS - Interface
> Lancement via Ansys Electronics Desktop

> Vue de l’interface :
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HFSS - InterfaceHFSS - Interface
> Structure d’un projet

Design HFSS

Projet Ansys Electronics Desktop (.aedt)

Modèle 3D

Conditions aux limites

Excitations

Analyses

Résultats (graphes 2D)

Résultats (Vue 3D superposées au modèle)

Calcul de « champs » supplémentaires (Near/Far-field)
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HFSS - Processus de conception / simulationHFSS - Processus de conception / simulation
> Création du modèle 3D(variables, définition objets géométriques, matériaux)

> Réglage ports/excitations et conditions aux limites

> Réglage solutions (fréq. et param. de calcul)

> Maillage adaptatif et analyse

> Post-processing

« An introduction to HFSS : Fundamental 
Principles, Concepts and Use »
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Cas d’étudeCas d’étude

> Ligne microruban de géométrie

> Simulation des paramètres S

Hsub = 1.6 mm

W = 2.5 mm

T = 35 µm

L = 100 mm

Lsub = 100 mm

Wsub = 100 mm

 Piste et plan de masse en cuivre, sur substrat FR4 (εr = 4.4)
 Origine du repère placé au centre de la ligne, sur le plan de masse.

x
y

z
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Sélection Type of solutionSélection Type of solution

> Driven modal ou Driven terminal (eigen mode omis ici, intéressant pour l’étude 
des modes de résonance des structures)

> Driven modal  paramètres S et tout est exprimé en puissance incidente/réfléchie

> Driven terminal  paramètres S et tout est exprimé en tension/courant
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Premières options à réglerPremières options à régler

> Tools > Options > General Options : 

Important : permettra de changer 
le type de solution (faisable à tout 
moment)

On commence avec une solution 
de type Driven modal.
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Premières options à réglerPremières options à régler

> Tools > Options > 3D Modeler Options :

> Dans le volet Drawing, cochez « Edit Properties
of New Primitives » 
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Création du projet / design HFSSCréation du projet / design HFSS

> File > New  création d’un nouveau 
projet

> Renommer en Microstrip_Project1

> Insertion d’un design HFSS, qu’on 
nommera Microstrip.

> File > Save as  sauvegarde du projet

> Réglage du type de solution (Tools > 
Options > General Options )

> Réglage des unités (en mm) : Modeler > 
Units
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Création des variablesCréation des variables

> Avant de se lancer dans la saisie du modèle 3D, toujours le dessiner sur papier et identifier les 
variables contrôlant sa géométrie, ainsi que les éventuelles équations les reliant.

> L’utilisation des variables va permettre de créer des objets paramétriques, facilement modifiables.

> On va entrer toutes les variables définissant la géométrie de la ligne microruban.

> HFSS > Design properties > bouton Add ou clic droit sur le nom du projet > Design properties
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Les objets géométriquesLes objets géométriques

> Sous HFSS, on peut représenter :

 Des volumes  tous les objets physiques du modèle; un matériau doit leur être 
attribué (maillage volumique lié à la FEM)

 Des surfaces  soit pour définir une condition aux limites (excitation, PEC, lumped
RLC …), soit pour définir un objet non réel (surface de mesure). Non maillé.

 Des lignes (edge)  Un objet non réel, uniquement dédié à la mesure. Non maillé.

 Des points  Un objet non réel, uniquement dédié à la mesure. Peu utilisé.
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Définition du modèleDéfinition du modèle

> La géométrie peut être créer à l’aide de 3 parallélépipèdes : piste, substrat, plan de masse.

> Clic sur Draw Box (dispo aussi dans Draw > Draw box)

> Commençons par le plan de masse.

> Cliquez n’importe où dans un plan XY pour placer le premier point, puis les 2 autres points pour 
définir la forme de dimensions arbitraires.

Drawing plane
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Définition du modèleDéfinition du modèle
> La fenêtre pop-up ci-dessous s’ouvre pour modifier les dimensions géométriques :

Nouvel objet 
géométrique créé
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Définition du modèleDéfinition du modèle
> Modifiez le nom, la couleur, la transparence de cet objet ainsi que les propriétés des matériaux en 

double-cliquant sur Box1
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Définition du modèleDéfinition du modèle
> Les contrôles 3D de la fenêtre graphique

Déplacement 
(Shift+CTRL) Rotation 

(ALT+CTRL)
Zoom +/-

(Shift+ALT) 

Fit view
(CTRL+D)
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Définition du modèleDéfinition du modèle
> Création du plan de masse

A cocher si on veut calculer les 
champs à l’intérieur de la piste
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Définition du modèleDéfinition du modèle
> Création de la piste

A cocher si on veut calculer les 
champs à l’intérieur de la piste
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Définition du modèleDéfinition du modèle
> Le modèle géométrique est terminé et doit ressembler à ça :

> Conseil : il peut être intéressant d’ajouter des notes perso à un modèle (HFSS > Edit design notes)
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Création des excitationsCréation des excitations

> Wave port : adapté au cas d’une ligne de 
transmission de section bien définie. Doit être 
appliqué sur une face externe du modèle

> Lumped port : pour représenter une 
excitation en tension dans un « gap ». Est 
appliqué à l’intérieur du modèle.

Les 2 excitations les plus courantes : 
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Création des excitationsCréation des excitations
> Changer le drawing plane  YZ

> Ajoutez les 2 variables suivantes : Wwave =25 mm et Hwave = 15 mm.

> Dessiner deux rectangles (Draw Rectangle) aux deux extrémités de la ligne, pour 
définir la position du port (de type Wave port). L’outil va calculer les propriétés de ce 
port (impédance carac.) à partir de la section de la ligne identifiée à l’intérieur de ce 
rectangle.
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Création des excitationsCréation des excitations

Wave ports

> Taille du waveport suggéré pour une ligne microstrip : 10w x 6h
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Création des excitationsCréation des excitations
> Sélectionnez le premier rectangle (Edit > Select > Faces), clic 

droit : Assign Excitation > Waveport

> Attribuez numéro 1

> Modes : laissez par défaut

> Post-processing :

> Terminez  on a créé le waveport1

> Même chose pour le second rectangle  waveport2
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Création des conditions aux limitesCréation des conditions aux limites
> Tout l’espace autour du modèle est considéré par défaut comme du Perfect Electric 

Conductor (PEC)  il faut le changer si on veut créer un volume ouvert.

> Définition de l’Air Box. 

> Dimensions recommandées : compromis entre précision et temps de calcul. Une distance 
d’au moins λ/4 entre le modèle et le bord rayonnant.

> Dessin d’une boite autour du design (Drawing Plane  XY et Draw Box)
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Création des conditions aux limitesCréation des conditions aux limites
> Création de limites de type « Radiation boundary » au-dessus du substrat  espace ouvert.

> Sélection des faces par : Edit > Select > By name
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Création des conditions aux limitesCréation des conditions aux limites
> Clic droit > Assign Boundary > Radiation
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Réglage des solutionsRéglage des solutions
> HFSS > Analysis setup > Add solution setup : on définit la fréquence à laquelle la 

structure sera maillée et le processus de calcul adaptatif sera effectué (nom  Setup1)
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Réglage des solutionsRéglage des solutions
> HFSS > Analysis setup > Add Frequency sweep: on définit la plage de fréquence sur 

laquelle on calcule les solutions (le maillage n’est pas raffiné à ces fréquences)

> On sélectionne Setup1.
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VérificationVérification
> HFSS > Validation check          : vérification du modèle (géométrie, excitation, conditions 

aux limites) et de l’analyse.

Quand tout va bien !
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Lancement de la simulationLancement de la simulation
> HFSS > Analyze All

> Temps de calcul dépendant du nombre de mailles, du nombre de fréquence, du nombre de 
passes pour converger …. 

> Toujours commencer par un nombre réduit de fréquences et de passes pour évaluer le 
temps de calcul requis pour le modèle et la simulation finale

> Avancement visible dans la fenêtre Progress.

> Si la simulation se termine correctement :
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Analyse des résultatsAnalyse des résultats
> HFSS > Results > Solution data

> Visualisation du temps de simulation, de la convergence, du maillage …
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Analyse des résultatsAnalyse des résultats
> Affichage des résultats de simulation de paramètres S : HFSS > Results > Create Modal 

Solution Data Report > Rectangular Plot

> Pour un affichage rapide : HFSS > Results > Create Quick Report …

> Courbes de résultats accessibles dans le Project Manager (Results).

> Double clic sur les courbes pour modifier le résultat à afficher, ajotuer des 
courbes …
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Analyse des résultatsAnalyse des résultats

> Double clic sur la zone graphique ou sur les courbes pour modifier leurs propriétés.

> Double clic sur la zone graphique et Export… ou Report2D > Export  export dans un 
fichier .csv, .dat, .txt, .jpg ….

Ajout de marqueurs

Zc simulé = 64 Ω
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Changement de type de solutionChangement de type de solution

> Sauvegarde du projet sous un autre nom : File > Save as : Microstrip_Project2

> Changement de type de solution : HFSS > Solution Type

> On supprimera les graphiques du précédent modèle, qui risque de mal se mettre 
à jour lors de la prochaine simulation.
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Modification de l’excitationModification de l’excitation

> Supprimez les excitations Waveport précédentes (dans le project
manager, catégorie Excitation)

> Sélectionnez le rectangle correspondant à l’ancien waveport1, puis 
HFSS > Excitation > Assign > Wave ports. 

> Même chose pour l’autre waveport.

> Dans le project manager, les excitations doivent apparaitre comme 
des sources de tensions
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Lancement de la simulationLancement de la simulation

> On conserve le même setup de solution

> Vérification du modèle

> Lancement de la simulation

> On trace les paramètres S11 et S12 : HFSS > Results > Create
TerminalSolution Data Report > Rectangular Plot
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Analyse des résultatsAnalyse des résultats

> De prime abord, on voit une différence sur les paramètres S (notamment S11) calculés 
avec la solution de type Modal (400 MHz: S11 = -12.26 dB (modal) vs. -18.85 dB (terminal), 
S12= -0.42 dB (modal) vs. -0.19 dB (terminal)).

> A considérer :
 Piste quasi adaptée 50 Ω (S11 sensible au moindre changement)

 Changement de type d’excitation  l’étape Port solution donne un résultat différent

 Maillage différent (5100 mailles en modal, 4076 en terminal)

> Le comportement simulé est cependant identique avec les 2 types de solution.

Zc simulé = 56 Ω


