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Filtrage de l’émission conduit produite par un 
convertisseur AC-DC Flyback 

 

L’objectif de ce bureau d’étude est de dimensionner le filtres CEM en entrée d’une alimentation à 
découpage de type Flyback, afin de limiter l’émission conduite et rendre le produit compatible avec 
le standard EN55022. L’étude s’appuiera sur la simulation (logiciels IC-EMC et WinSPICE), ainsi 
que sur la base de sélection de composants REDEXPERT, fournie par Würth Elektronik 
(https://www.we-online.com/redexpert/). 

A l’issue de ce bureau d’étude, un rapport sera demandé présentant les résultats et les conclusions 
des différentes étapes de conception et de validation du filtre CEM. 

 

I. Préalable : Installation des logiciels de simulations et des 
librairies 

Le logiciel de saisie de schématique et d’analyse des résultats, IC-EMC v2.9 (version au moins 
postérieure à celle du 7/11/2025), est téléchargeable à l’adresse suivante : http://www.ic-
emc.org/download/IC-EMC-2v9.zip.  

Le simulateur SPICE utilisée, WinSPICE, est téléchargeable ici : http://www.ic-
emc.org/download/WinSpice_1.05.zip. A noter que les logiciels de simulation Ngspice 
(https://ngspice.sourceforge.io/download.html) et LTSPICE (https://www.analog.com 
/en/resources/design-tools-and-calculators/ltspice-simulator.html) peuvent être utilisés. 

Dézipper les deux dossiers dans un emplacement connu. Le lancement du logiciel IC-EMC se fait 

en lançant l’exécutable ic_emc.exe . Pour que IC-EMC puisse lancer automatiquement 
l’exécution des simulations par WinSPICE, vous devez indiquer dans IC-EMC l’emplacement de 
l’exécutable wspice3.exe. Pour cela, sur IC-EMC, cliquez sur le menu File > Simulator > 
Configurations. Un écran dédié s’ouvre pour indiquer le chemin d’accès de l’exécutable de 
WinSPICE (.\WinSpice 1.05\ wspice3.exe). 

Les modèles des composants de filtrage, proposés par Wurth Elektronik et qui seront utilisés durant 
les phases de simulation de ce bureau d’étude, sont fournis par plusieurs librairies (fichiers .lib) : 

▪ Modèles condensateurs céramique WCAP-CCSA : WCAP-CSSA.lib 

▪ Modèles condensateurs film WCAP-FTXX : WCAP-FTXX.lib 

▪ Modèles common-mode choke CMB : WE-CMB-models.lib 

▪ Modèles common-mode choke CMBNC : WE-CMBNC-models.lib 

Ces librairies sont accessibles dans le dossier zippé modele_BE_CE_CERE.zip. 

 

II. Cahier des charges 

Type de convertisseur AC-DC, flyback 

Puissance max. 60 W 

https://www.we-online.com/redexpert/
http://www.ic-emc.org/download/IC-EMC-2v9.zip
http://www.ic-emc.org/download/IC-EMC-2v9.zip
http://www.ic-emc.org/download/WinSpice_1.05.zip
http://www.ic-emc.org/download/WinSpice_1.05.zip
https://ngspice.sourceforge.io/download.html
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Tension d’entrée 85 – 264 Vrms, 220 Vrms nominal 

Tension de sortie 12 V 

Courant de sortie max. 2 A 

Fréquence de hachage 200 kHz 

Ondulation max. en sortie 2 % 

Temps de commutation 10 ns 

Courant pic en entrée 3.5 A 

Condensateur de filtrage en sortie du 
redresseur 

120 µF +/- 20 %, 400 V, aluminium 

470 nf +/- 10%, 500 V, céramique X7R, 1812 

Classe attendue pour les condensateurs du 
filtre CEM d’entrée 

X2 et Y2. La capacité Cy totale est limitée à 10 
nF 

 

L’alimentation à découpage sera assemblée sur un circuit imprimé FR4 deux couches d’épaisseur 
1.6 mm. Dans la première partie du BE, l’influence du routage sera négligée.  

Contraintes pour le dimensionnement des filtres : le nombre, la taille et le volume des composants 
devra être optimisé pour réduire le coût de la BOM. 

Tests d’émission conduite : L’ensemble des tests CEM seront réalisés avec l’alimentation à 
découpage montée à 5 cm d’un plan conducteur de référence, considérée comme la référence de 
masse.  

Limite d’émission conduite à vérifier sur l’entrée : EN55022 classe B, mesure en tension sur 
Réseau Stabilisateur d’Impédance en Ligne (RSIL) ou LISN 50 µH // 50 Ω. Un modèle du RSIL est 
fourni dans le dossier zippé modele_BE_CE_CERE.zip : LISN_model.sym. Les tensions obtenues 
sur les terminaux de mesure du RSIL ne doivent pas dépasser la limite notée classe B. La 
construction interne du modèle est donnée par le fichier LISN_model.sch. 

 
 

Limite d’émission conduite définie par le standard EN55022 (à gauche) et symbole du modèle du RSIL utilisé 
dans le bureau d’étude 

III. Modèle de simulation du convertisseur AC-DC 

Le fichier ACDC_CE_model.sch (disponible dans le dossier zippé modele_BE_CE_CERE.zip, 
fourni avec le sujet de BE sur www.alexandre-boyer.fr/enseignements) contient un modèle 

http://www.alexandre-boyer.fr/enseignements
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électrique équivalent du convertisseur AC-DC, dédié uniquement à la simulation de son émission 
conduite. Il s’agit d’un modèle petit signal haute fréquence (HF) dédié uniquement à la simulation 
de son émission conduite. Ce modèle, simplifié, reproduit l’émission de mode différentiel et de 
mode commun en entrée, et l’émission de mode différentiel en sortie. Le modèle intègre les 
condensateurs de filtrage en sortie du redresseur et en sortie du convertisseur, mais aucun autre 
élément de filtrage CEM. La figure ci-dessous donne une image du modèle électrique équivalent. 

Les terminaux (symbole ) Vphase et Vneutre sont respectivement, et Ref_Plane la connexion 
vers le plan de référence de masse. Les sources équivalentes de bruit de mode différentiel et de 
mode commun sont ajustable via des paramètres (commande .Param). Par défaut, le modèle est 
réglé pour simuler l’émission conduite du convertisseur alimenté sous 220 Vac et un courant 
maximal en entrée. 

 

Modèle équivalent HF du convertisseur AC-DC pour la simulation de l’émission conduite en entrée 
(ACDC_CE_model.sch) 

IV. Questions 

L’objectif des questions ci-dessous est de vous guider dans l’analyse de l’émission conduite 
produite par le modèle du convertisseur AC-DC, dans le dimensionnement des filtres CEM et la 
modélisation des composants de filtrage. Ces différentes questions vous aideront à remplir le 
rapport de dimensionnement du filtre.  

 

 

1. A partir du modèle ACDC_CE_model.sch, ajoutez le modèle du RSIL (LISN_model.sym) pour 
constituer le modèle de simulation de l’émission conduite en entrée du convertisseur AC-DC. Où et 
comment doit-on connecter les différents terminaux du modèle du RSIL ? 

Sauvegardez ce nouveau modèle sous un autre nom que ACDC_CE_model.sch. 
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2. A partir de votre modèle, simulez le niveau d’émission conduite en entrée du convertisseur AC-
DC.  

On utilisera pour cela une simulation transitoire, avec un temps total de 100 µs et un pas de 1 ns. 
Pour insérer une ligne d’analyse, cliquez dans le menu Insert > Insert Analysis Line. Sur IC-EMC, la 
mesure des tensions se fait à l’aide des « probes » suivantes, disponibles dans la palette de 
symbole : 

•  : mesure de la tension d’un nœud par rapport à la masse 

•  : mesure de la tension différentielle entre deux nœuds 

•  : mesure de la tension de mode commun entre deux nœuds  

Lancez la simulation WinSPICE en cliquant sur le bouton dans la barre d’outils. A l’issue de la 

simulation, vous pouvez fermer WinSPICE. Sur IC-EMC, cliquez sur le bouton  dans la barre 
d’outils pour tracer les spectres des tensions simulées et les comparer aux limites standards 
(affichables à partir de l’onglet Envelop & Limits). 

 

3. La limite d’émission conduite définie par le standard EN55022 porte sur les tensions mesurées 
sur la phase et le neutre à travers le RSIL. Il est donc indispensable de simuler la tension HF sur 
ces deux nœuds. Cependant, pourquoi est-il avantageux pour la conception du filtre de distinguer 
les contributions de type mode commun et mode différentiel de l’émission conduite ? 

 

4. Etablir les niveaux d’atténuation requis par le filtre CEM. On distinguera l’atténuation à apporter 
en mode commun et en mode différentiel.  

 

5. Conception initiale du filtre CEM  

a. Proposez des valeurs pour les composants du filtre CEM d’entrée dans sa version 
minimale. A partir de REDEXPERT, proposez des références de composants, en indiquant les 
valeurs, la technologie, les dimensions. Justifiez leur choix. Indiquez l’ordre du filtre proposé, les 
fréquences visées, les atténuations attendues. Sélectionnez seulement des composants dont les 
modèles sont disponibles dans les librairies fournies ! 

 

b. Proposez un modèle de simulation l’atténuation ou la perte par insertion en mode 
commun et en mode différentiel apportée par ce filtre lorsqu’il est terminé par des charges 50 Ω.  

 

Le calcul de la perte par insertion se fera en utilisant une simulation petit signal .AC appliquée sur 
le filtre seul. Placez une source d’excitation sur un terminal du filtre (avec l’impédance de sortie 
requise) et la charge terminale sur l’autre terminal du filtre.  

Configurez une simulation AC : l’analyse à insérer à l’aide du menu Insert > Insert Analysis Line est 
une simulation AC, avec balayage fréquentielle logarithmique de 100 points/décadre, entre 1 kHz et 
1 GHz (exemple : .AC DEC 100 1k 1G).   

Le tracé de l’atténuation se fait par l’intermédiaire de l’outil EMC > AC Analysis, disponible à l’aide 

du bouton  dans la barre d’outils. Les paramètres pourront être tracés en dB. 
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c. Simulez l’atténuation de mode commun et de mode différentiel du filtre. Est-il suffisant 
pour respecter la limite EN55022 classe B ? Les atténuations simulées sont-elles conformes au 
dimensionnement de la question 5.a. Qu’est-ce qui explique les différences ? 

 

6. Simulation de la réduction de l’émission conduite en entrée avec le filtre CEM d’entrée dans sa 
version initiale. 

 a. Intégrez le modèle du filtre CEM d’entrée au modèle développé à la question 2, et 
simulez l’émission conduite en entrée. Cette première version de filtre permet-elle d’être en 
conformité avec le standard EN55022 ? 

 

 b. L’atténuation apportée par le filtre est-elle en conformité avec les pertes par insertion 
précédemment calculées ? Pourquoi ? 

 

 c. Evaluez l’influence et l’effet de la position des différents composants du filtre. Vous 
pourrez supprimer un composant et simuler l’émission conduite. Des composants sont-ils 
superflus ? Commentez le rôle des composants du filtre. 

 

7. Amélioration de la version initiale du filtre (si nécessaire) 

La première version du filtre n’est peut-être pas encore satisfaisante vis-à-vis du respect de 
la limite EN55022. De plus, même si cette limite est satisfaite, on peut se demander s’il est possible 
de respecter cette limite avec des composants plus compacts. Dans ces deux cas de figure, on 
s’intéresse maintenant aux améliorations possibles sur le filtre. 

a. En analysant les manques du filtre précédent, proposez différentes pistes d’amélioration 
du filtre pour respecter la limite d’émission conduite. 

b. Testez en simulation ce(s) piste(s) et proposez une version améliorée du filtre. 
Commentez les résultats obtenus. 

 

Dans cette dernière partie, on s’intéresse à l’influence sur l’émission conduite de la commande du 
convertisseur (son temps de transition) et du placement-routage des condensateurs de filtrage. On 
s’appuiera sur la simulation pour déterminer plusieurs règles de conception faible bruit. 

 

8. Le circuit de commande PWM permet de régler les temps de transition via un système de slew 
rate réglable afin de diminuer les pertes par commutation. Trois valeurs de temps de transition sont 
possibles : 10, 20 et 30 ns. Par défaut, celui-ci avait été réglé à 10 ns. En utilisant le modèle 
électrique de la partie 1, on souhaite évaluer l’influence du temps de transition et s’il est possible de 
simplifier le filtre CEM. On s’intéressera uniquement aux deux valeurs extrêmes de temps de 
commutation. 

 a. Modifiez le schéma électrique du convertisseur sans filtre d’entrée et simulez le niveau 
d’émission conduite en entrée avec ce nouveau temps de transition (paramètre Tr du modèle). 

 b. Evaluez l’amélioration ou la dégradation des niveaux d’atténuation requis pour le filtre 
CEM. Ces observations sont-elles explicables ? 

 c. Est-il possible d’éliminer des éléments de filtrage ? Quelle amélioration potentielle peut 
apporter une augmentation du temps de transition ? Avec quelle(s) contrepartie(s) ? 
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9. Dans une précédente version d’alimentation à découpage, l’ensemble des condensateurs de 
filtrage étaient connectés aux lignes de phase et de neutre par l’intermédiaire de pistes de 2 mm de 
large et de 1 cm de long. A partir du modèle du convertisseur et de son filtre, on souhaite analyser 
si ces pistes ont influence et quelle règle de placement-routage des condensateurs adopter. 

a. A l’aide des informations sur le routage des condensateurs et l’outil Interconnect 
Parameters (menu Tools), déterminez les paramètres électriques R, L, C d’une piste de connexion 
d’un condensateur. A partir des valeurs calculées, entre les effets résistifs, inductifs et capacitifs, 
le(s)quel(s) pourraient avoir une influence majeure sur l’émission conduite ? 

b. Proposez une modification simple du modèle de simulation du convertisseur et de son 
filtre pour simuler l’effet du placement-routage des condensateurs. 

c. Quelle est l’influence du placement - routage des condensateurs sur l’émission conduite ?  

d. Proposez une règle de placement-routage des condensateurs permettant de garantir une 
bonne efficacité du filtre d’émission conduite.  

 


